Original Files?

Apr 4, 2012 at 7:54 PM
Edited Apr 4, 2012 at 8:01 PM

This script worked great for me until a full backup operation was interrupted accidentally and the backup never finished.  The archive is corrupt but worse the files I was backing up are gone?

I tried looking in the working directory and the files are not there.  Where are the original files?

Any help appreciated.

Apr 5, 2012 at 10:12 AM

Hello n4pd3f,

the script does not delete original files unless you have launched it with the --move switch. But in that case the delete operation is performed only if the process of archiving completes without errors.

The working directory (where you're looking for original files) contains only junction points to original directories and files. If you delete anything within the working directory using windows explorer it's likely you have deleted your files. As I mentioned several times in the pages of this project : "DO NOT USE WINDOWS EXPLORER TO DELETE JUNCTIONS AS IT TRAVERSES THE LINK AND MAY REMOVE YOUR REAL FILES AND FOLDERS"

Aug 31, 2013 at 12:59 PM
Hello Andrea,

I can confirm that script deletes source folders from time to time. This just happened for me second time, scheduler started backup of all my work folders and deleted subfolders on completion. I dfo not know reason for this because I neither used work folders this time nor touched backup process.

To illustrate the issue I have backup folders like

Project1 and Project 2 folder are used for backup. On process completion only 2 empty folders remain: Work/Project1, Work/Project2

Even if I find this script very useful I had to stop using it because I do not want to lose my data :(
Sep 2, 2013 at 9:44 AM
Hello Andreyi,
thank you for your follow up.

As already mentioned for n4pd3f the only way for the script to delete something is when you launch it with the --move switch enabled. In all other cases the routine which involves the deletion of original files is never called. Tested with thousands backups. In my humble opinion there must be something else in your file system which causes the deletion.

All the best.
Sep 2, 2013 at 2:11 PM
I understand that you mentioned about move option. I can confirm that my scripts do not use move option. I set up these scripts almost 2 years ago (so hundreds of runs as well)

I guess scirpt does not remove junctions in some point and deletes source files because of that
Sep 2, 2013 at 2:20 PM
This is very "unlike to happen" behavior. I double checked the script (you can do that too as it is in clear text) and in all my sims (like the ones of other hundreds of users) you and n4pd3f are the only ones who have reported this.

Can you please better describe the environment ? (os ?)
Is it possibile for you to post a copy of your selection file ?

Best regards.